Google closes 81 vulnerabilities in Android

Critical vulnerabilities are mainly found in Qualcomm’s components. Under certain circumstances, attackers can smuggle and execute malicious code. Android versions 8.1, 9, 10, and 11 are affected.

As usual, Google released new security updates for Android at the start of the month. Fixes are now available for internal Pixel smartphones. They’ve also been known to Google’s Android partners for at least four weeks – their updates will be available in the coming days or maybe weeks.

On Patch Day for March, Google blocked a total of 81 vulnerabilities. 38 vulnerabilities were described by Google at Android Security BulletinAnother 43 inches Pixel update flyer. It’s also distributed over the security lease levels on March 1 and March 5.

Devices with the March 1 patch level are protected against attacks on 11 vulnerabilities in the Android Runtime, Framework, System, and Google Play System components. The developers also rated the bug as critical. Under certain circumstances, smuggling and execution of malicious code is permitted under Android 8.1, 9, 10 and 11. In addition, all supported Android devices are subject to unauthorized expansion of user rights and the theft of confidential information.

The rest of the fixes are part of the updates that arrive at the March 5th Security Patch level. Among other things, Google is filling the holes in the kernel, in Qualcomm’s chipset bootloader, and in the media framework. Additional vulnerabilities in Qualcomm’s closed source components are also rated “critical” of the highest severity.

Some of them are also allowed for Pixel device users We are pleased to correct errors unrelated to security. The developers have improved the stability of Android Auto. Kernel updates are also available for Pixel 3, 3XL, 3a, 3a XL, 4, 4XL, 4A, 4a 5G, and Pixel 5 smartphones.

READ  WhatsApp risk to users: If you get this message, it might already be too late

Manufacturers such as LG, Huawei, Motorola, Nokia, OnePlus, Oppo and Samsung will soon provide their corrections. However, their security advisories are not yet available. You may be limited to incorporating reforms to the first correction level of March. In this case, users will have to wait until at least April to receive the patch level corrections on the 5th of March.

Leave a Reply

Your email address will not be published. Required fields are marked *